Resolved
Circleback is now able to join all meetings.
Investigating
We are still investigating Circleback not joining some meetings.
Investigating
Calendar integration has recovered. We are still investigating Circleback not joining some meetings.
Investigating
We are investigating an issue where Circleback is not able to join meetings or load calendar events for some users.